"poolht" and "spaht" Never Report On Status (Value 2)

kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

"poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Wed Oct 11, 2017 2:27 pm

The Command Reference for the HTTP Interface suggests the value for the "poolht" and "spaht" nodes in the XML are 0 for Off, 1 for Enabled, and 2 for On (heating). However, my interface never reports a value of 2 for the poolht or spaht nodes in the status HTML or through the TCP Serial connection, nor does the website or mobile app ever show a status other than "Enabled" or "Off". I am currently running v. 1.6.9 TCP Serial firmware with a Jandy Aqualink RS8/Onetouch, but I was previously running the ISY/Vera firmware v. 1.6.9, and I don't believe that firmware ever reported a 2 (On) for poolht or spaht, either. The Onetouch keypad properly shows the red light when heating.

I would expect this would work on both the HTTP Interface and the TCP Serial interface. Can you let me know if it is something wrong with my setup, or is it not supported in the firmware?
autelis
Site Admin
Posts: 1123
Joined: Tue Nov 30, 2010 1:02 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by autelis » Wed Oct 11, 2017 4:33 pm

Can you please post your Jandy firmware version and if you have a shared heater or dual heaters.
Autelis.com Staff
kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Wed Oct 11, 2017 5:32 pm

Model 8156 Type RS-8 Combo Firmware JJ
(Autelis reports Model 6520)
Single, shared heater.

I don't like where this one's going! :)
autelis
Site Admin
Posts: 1123
Joined: Tue Nov 30, 2010 1:02 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by autelis » Thu Oct 12, 2017 4:47 pm

The only other report of heater status problems we have seen was with a dual heater setup. We are unable to reproduce but we do not have rev JJ for testing.
Autelis.com Staff
kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Thu Oct 12, 2017 5:31 pm

But it is supposed to send a command when the heater turns on or off, then? Is there a diagnostic log on the Autelis unit that I can access?

Is there a newer version of the TCP Serial Port firmware for Jandy Aqualink I could try?
autelis
Site Admin
Posts: 1123
Joined: Tue Nov 30, 2010 1:02 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by autelis » Fri Oct 13, 2017 3:04 pm

Yes it should update between 1 and 2. There is no log and no recent changes related to heater status.
Autelis.com Staff
kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Tue Oct 17, 2017 8:49 pm

I have tried several different versions of firmware 1.6.9 (standard, advanced, ISY/Vera, TCP Serial Port) and even tried a 1.6.13 floating around out there and none of them ever show the Heater On (value 2) - just Enabled. This is true whether I am looking at the webpage, the mobile app, polling the status.xml, or reading the TCP connection. I thought I saw a 1.6.5 out there earlier and was keen to try that, but I couldn't find it again.

I understand you don't have Rev. JJ firmware to test against, but the Wiki for the TCP Serial Port firmware does say it should work with Rev. I or better, so JJ should work if I worked. Is there anyway for me to test this onsite here and provide technical info to you to analyze? I would really like to capture the heater turning on so I could control a vent fan in the pump house (without using one of my RS8 relays).
autelis
Site Admin
Posts: 1123
Joined: Tue Nov 30, 2010 1:02 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by autelis » Thu Oct 19, 2017 3:43 pm

You can try the legacy firmware but you would lose the onetouch interface and the ability to set setpoints using the API. We will continue investigating. We are not aware of any other reports of this issue.
Autelis.com Staff
kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Fri Oct 20, 2017 8:19 am

Ok, I will try the legacy firmware to at least see if it correctly returns the heater status.

I will reiterate (based on your reiteration that you have had no other reports on the issue) that my OneTouch Keypad correctly shows the status of the Heater in the 'Equipment On/Off" page, i.e. "POOL HEAT ON" or "POOL HEAT ENA", and via the red/green LED as well. This is the case whether I look at the OneTouch Keypad directly or through the keypad.htm on the Autelis Pool Control website. However, the temperature.htm page on the Autelis Pool Control website only ever shows "Pool Heat: Enabled" with a green background and never "Pool Heat: On" or a red background, as indicated in the the Product Page for Pool Control for Jandy/Zodiac.
kingwr
Posts: 19
Joined: Thu Dec 22, 2016 9:57 pm

Re: "poolht" and "spaht" Never Report On Status (Value 2)

Post by kingwr » Fri Oct 20, 2017 8:44 am

Pool Control Legacy (PC100JZL) Firmware 1.6.9 DOES properly show the Pool Heat status both on the temperature.htm page (Enabled and On with green and red backgrounds respectively) and in the status.xml page from the website. However, as you mentioned there is far too many things broken in this version to use it.

Perhaps the difference in the way Pool Heat and Spa Heat status are handled between the legacy (PC100JZL) and non-legacy (PC100JZ) versions of the 1.6.9 firmware can point to where the problem may lie in it not working with Rev. JJ firmware in the Jandy Aqualink?

BTW, was firmware 1.6.9 developed and tested against Rev. I? I don't see anything in the Jandy firmware revisions that would suggest why this would work with Rev. I and not Rev. JJ. Rev. K and Rev. QQ are where all the big changes seem to be.
Post Reply